Recurring Payments - Defining a Specific Stripe API Version

As of Recurring Payments 2.7.18, you have the ability to define the version of the Stripe API you would like to use. This can be useful when you do not have the ability to roll back or change your API version from within your Stripe Dashboard.

Defining your Stripe API Version

In your wp-config.php file, find this line:

/* That's all, stop editing! Happy blogging. */

Place the following right above it:

define( 'EDD_STRIPE_API_VER', '2018-01-23' );

You can see a complete list of API Versions over at Stripe: https://stripe.com/docs/upgrades#api-changelog

Please Note: If possible, it is always best to define your API version from within your Stripe Dashboard. This method of defining it is for edge cases where it is not possible to use a specific version of the API via the provided methods within Stripe. You can see full documentation on the Stripe API versions within their docs.